АНГ | РУС

Совершенство достигнуто, не тогда, когда нечего добавить,
а когда нечего убрать.

Антуан де`Сент-Экзюпери

 

Bootstrap 4 - как этим пользоваться.

В этой статье я бы хотел рассказать как используется bootstrap 4 , какие изменения коснулись новой версии.

Начнем по порядку. Bootstrap 4 имеет ряд отличий от предыдущей версии Bootstrap 3.

Но мы будем рассматривать его так, как будь то не знаем о нем ни чего и пытаемся разобраться с нуля.

Моя статья адресована тем, кто плохо владеет английским, и не сталкивался с подобными технологиями.

ПРЕДИСЛОВИЕ.

Этот инструмент прежде всего сделан для того, чтоб облегчить верстку. Создать адаптивный дизайн который будет удобно восприниматься пользователем на любой платформе. А так же систематизировать ваш контент.

1. Быстрый старт

Хотите быстро добавить Bootstrap в свой проект? Используйте компакт-диск Bootstrap CDN, предоставляемый бесплатно в MaxCDN. Использование диспетчера пакетов или загрузка исходных файлов? Перейдите на страницу загрузки. Скопируйте-вставьте таблицу стилей в свои перед всеми остальными таблицами стилей, чтобы загрузить  CSS.

Загрузка

Загрузите Bootstrap, чтобы получить скомпилированный CSS и JavaScript, исходный код или включить его с вашими любимыми менеджерами пакетов, такими как npm, Bower, RubyGems и многое другое.

Скомпилированные CSS и JS

Загрузите готовый скомпилированный код для Bootstrap v4.0.0. 0.0-бета, чтобы легко упасть в ваш проект, который включает в себя:

Скомпилированные и минифицированные связки в CSS (default, grid-only и Reboot-only)
Скомпилированные и уменьшенные плагины JavaScript

Это не включает документацию, исходные файлы или дополнительные зависимости JavaScript (jQuery и Popper.js).

Download

Исходный файл

Скомпилируйте Bootstrap с помощью собственного конвейера ресурсов, загрузив исходные файлы Sass, JavaScript и документации. Этот параметр требует дополнительной оснастки:

Компилятор Sass (Libsass or Ruby Sass поддерживается) для компиляции в CSS.
Автофиксатор для префикса поставщика CSS

Если вам нужны инструменты сборки, они включены для разработки Bootstrap и это документы, но они, вероятно, непригодны для ваших собственных целей.

Download source

Bootstrap CDN

Пропустите загрузку с помощью загрузочного CDN для доставки кэшированной версии скомпилированного CSS и JS Bootstrap в проект.

<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta/css/bootstrap.min.css" integrity="sha384-/Y6pD6FV/Vv2HJnA6t+vslU6fwYXjCFtcEpHbNJ0lyAFsXTsjBbfaDjzALeQsN6M" crossorigin="anonymous">
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta/js/bootstrap.min.js" integrity="sha384-h0AbiXch4ZDo7tp9hKZ4TsHbi047NrKGLO3SEJAg45jXxnGIfYzk4Si90RDIqNm1" crossorigin="anonymous"></script>

Если вы используете наш скомпилированный JavaScript, не забудьте включить CDN версии jQuery и Popper.js, прежде чем он.

<script src="https://code.jquery.com/jquery-3.2.1.slim.min.js" integrity="sha384-KJ3o2DKtIkvYIK3UENzmM7KCkRr/rE9/Qpg6aAZGJwFDMVNA/GpGFF93hXpG5KkN" crossorigin="anonymous"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js" integrity="sha384-b/U6ypiBEHpOf/4+1nzFpr53nxSS+GLCkfwBdFNTxtclqqenISfwAzpKaMNFNmj4" crossorigin="anonymous"></script> 

Менеджер пакетов

Загрузите исходные файлы Bootstrap почти в любой проект с некоторыми из самых популярных менеджеров пакетов. Независимо от того, менеджер пакетов, Bootstrap потребует компилятора Sass и Autoprefixer для установки, которая соответствует нашим официальным скомпилированным версиям.

nmp

Установите Bootstrap в приложения с питанием от узлов с пакетом npm:

 

npm install bootstrap@4.0.0-beta

require ('bootstrap') загрузит все плагины jQuery Bootstrap в объект jQuery. Сам загрузочный модуль ничего не экспортирует. Вы можете вручную загрузить плагины jQuery Bootstrap по отдельности, загрузив файл /JS/*.JS - файлы в каталоге верхнего уровня пакета.

Пакет начальной загрузки по.json содержит дополнительные метаданные в следующих разделах:

 

RubyGems

Установите Bootstrap в приложения Ruby с помощью Bundler (рекомендуется) и RubyGems, добавив в файл Gemfile следующую строку:

gem 'bootstrap', '~> 4.0.0.alpha6'

Кроме того, если вы не используете Bundler, вы можете установить gem, выполнив следующую команду:

gem install bootstrap -v 4.0.0.alpha6

См. README gem`s для более подробной информации.

Composer

Вы также можете установить и управлять Sass Bootstrap и JavaScript с помощью Composer:

composer require twbs/bootstrap:4.0.0-beta

Bower

Установка и управление Sass Bootstrap и JavaScript с помощью Bower.

bower install bootstrap#v4.0.0-beta

NuGet

Если вы разрабатываете в .NET, вы также можете установить и управлять CSS Bootstrap или Sass и JavaScript с помощью NuGet:

Install-Package bootstrap -Pre
Install-Package bootstrap.sass -Pre

Для -Pre требуется  имеет стабильный релизBootstrap v4.


На этом пока все в следующей статье мы рассмотрим "Общее представление" , что все таки является основой Bootstrap.